use strict;
my $str = '25
15,81
94.5498
+897
151 516,561 894
89.9894_56
-9';
my $regex = qr/(?<sign>[+-])?(?<int>\d(?:[\d_ ]*\d+)?)(?:(?:\s*[,.]\s*)(?<decimal>\d(?:[\d_ ]*\d+)?))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}