// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<sign>[+-])?(?<int>\d(?:[\d_ ]*\d+)?)(?:(?:\s*[,.]\s*)(?<decimal>\d(?:[\d_ ]*\d+)?))?").unwrap();
let string = "25
15,81
94.5498
+897
151 516,561 894
89.9894_56
-9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}