package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((https?):\/\/)?(www.)?twitter\.com(\/@?(\w){1,15})\/status\/[0-9]{19}\?`)
var str = `https://twitter.com/PetsDrawn/status/1516129999434436609?s=20&t=rH3i0GUrTKOgp_ryRlE9DA`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}