import re
regex = re.compile(r"((https?):\/\/)?(www.)?twitter\.com(\/@?(\w){1,15})\/status\/[0-9]{19}\?")
test_str = "https://twitter.com/PetsDrawn/status/1516129999434436609?s=20&t=rH3i0GUrTKOgp_ryRlE9DA"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")