import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https?):\\/\\/)?(www.)?twitter\\.com(\\/@?(\\w){1,15})\\/status\\/[0-9]{19}\\?";
final String string = "https://twitter.com/PetsDrawn/status/1516129999434436609?s=20&t=rH3i0GUrTKOgp_ryRlE9DA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}