import Foundation
let pattern = #"((https?):\/\/)?(www.)?twitter\.com(\/@?(\w){1,15})\/status\/[0-9]{19}\?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://twitter.com/PetsDrawn/status/1516129999434436609?s=20&t=rH3i0GUrTKOgp_ryRlE9DA"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}