package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Uis)^\[\[\%([A-z0-9\-]+)\?\s+\&namespace\=\`(.*)\`\s+\&topic\=\`(.*)\`\]\]`)
var str = `[[%mt4se-amuk-tradeterminal-4-p-59? &namespace=\`main_uk\` &topic=\`TradeTerminal\`]]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}