re = /^\[\[\%([A-z0-9\-]+)\?\s+\&namespace\=\`(.*)\`\s+\&topic\=\`(.*)\`\]\]/i
str = '[[%mt4se-amuk-tradeterminal-4-p-59? &namespace=`main_uk` &topic=`TradeTerminal`]]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end