import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[\\[\\%([A-z0-9\\-]+)\\?\\s+\\&namespace\\=\\`(.*)\\`\\s+\\&topic\\=\\`(.*)\\`\\]\\]";
final String string = "[[%mt4se-amuk-tradeterminal-4-p-59? &namespace=`main_uk` &topic=`TradeTerminal`]]";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}