#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:100|\d{1,2}(?:\.\d{1,2})?)$"
Local $sString = "0" & @CRLF & _
"0.1" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"11.1" & @CRLF & _
"11.11" & @CRLF & _
"100" & @CRLF & _
"-1" & @CRLF & _
"100.1" & @CRLF & _
"111" & @CRLF & _
"1+1" & @CRLF & _
".1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")