// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:100|\d{1,2}(?:\.\d{1,2})?)$").unwrap();
let string = "0
0.1
1
11
11.1
11.11
100
-1
100.1
111
1+1
.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}