$re = '/^(?:100|\d{1,2}(?:\.\d{1,2})?)$/m';
$str = '0
0.1
1
11
11.1
11.11
100
-1
100.1
111
1+1
.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);