import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:100|\\d{1,2}(?:\\.\\d{1,2})?)$";
final String string = "0\n"
+ "0.1\n"
+ "1\n"
+ "11\n"
+ "11.1\n"
+ "11.11\n"
+ "100\n"
+ "-1\n"
+ "100.1\n"
+ "111\n"
+ "1+1\n"
+ ".1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}