using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)cta=([^&]+)";
string input = @"/webforms/onlineform/personal-loan/web/personalloan.aspx?cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}