re = /(?i)cta=([^&]+)/m
str = '/webforms/onlineform/personal-loan/web/personalloan.aspx?cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end