$re = '/(?i)cta=([^&]+)/m';
$str = '/webforms/onlineform/personal-loan/web/personalloan.aspx?cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);