package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)cta=([^&]+)`)
var str = `/webforms/onlineform/personal-loan/web/personalloan.aspx?cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan&cta=productpage-calculator-mobile-floating-personalloan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}