using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}";
string input = @"123-456-7890
(123)456-7890
123 456-7890
(123-456-7890
(123)-456-7890
1234567890
pattern: (\()?\d{3}(?(1)\)|-)\d{3}-\d{4}
- part1: (\()?
- part2: (?(1)\)|-)
- part3: d{3}-\d{4}
pattern2: (?<!\()(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}