import Foundation
let pattern = #"(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
123-456-7890
(123)456-7890
123 456-7890
(123-456-7890
(123)-456-7890
1234567890
pattern: (\()?\d{3}(?(1)\)|-)\d{3}-\d{4}
- part1: (\()?
- part2: (?(1)\)|-)
- part3: d{3}-\d{4}
pattern2: (?<!\()(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)