re = /(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}/mi
str = '123-456-7890
(123)456-7890
123 456-7890
(123-456-7890
(123)-456-7890
1234567890
pattern: (\\()?\\d{3}(?(1)\\)|-)\\d{3}-\\d{4}
- part1: (\\()?
- part2: (?(1)\\)|-)
- part3: d{3}-\\d{4}
pattern2: (?<!\\()(\\()?\\d{3}(?(1)\\)|-)\\d{3}-\\d{4}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end