$re = '/(\()?\d{3}(?(1)\)|-)\d{3}-\d{4}/mi';
$str = '123-456-7890
(123)456-7890
123 456-7890
(123-456-7890
(123)-456-7890
1234567890
pattern: (\\()?\\d{3}(?(1)\\)|-)\\d{3}-\\d{4}
- part1: (\\()?
- part2: (?(1)\\)|-)
- part3: d{3}-\\d{4}
pattern2: (?<!\\()(\\()?\\d{3}(?(1)\\)|-)\\d{3}-\\d{4}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);