const regex = /\d+H?\d*M?\d*S?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+H?\\d*M?\\d*S?$', 'gm')
const str = `1M3W4D22H6M3S
10D12H
10M
1Y8W3D
2M12H`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}