import re
regex = re.compile(r"\d+H?\d*M?\d*S?$", flags=re.MULTILINE)
test_str = ("1M3W4D22H6M3S\n"
"10D12H\n"
"10M\n"
"1Y8W3D\n"
"2M12H")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")