$re = '/\d+H?\d*M?\d*S?$/m';
$str = '1M3W4D22H6M3S
10D12H
10M
1Y8W3D
2M12H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);