$re = '/(www\.|https?:\/\/)?[a-z0-9]+\.[a-z0-9]{2,4}\S*\b/';
$str = 'example.co.uk (main site: example.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);