re = /(www\.|https?:\/\/)?[a-z0-9]+\.[a-z0-9]{2,4}\S*\b/
str = 'example.co.uk (main site: example.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end