using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{3}( to |-)[A-Z]{3}";
string input = @"I recently traveled YWG-LHR and returned home from EDI to YWG with AC Rouge. I must say I was pleasantly surprised with how well the trip went in both directions, but I'm glad I didn't have to transit in ORD.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}