const regex = /[A-Z]{3}( to |-)[A-Z]{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{3}( to |-)[A-Z]{3}', 'gm')
const str = `I recently traveled YWG-LHR and returned home from EDI to YWG with AC Rouge. I must say I was pleasantly surprised with how well the trip went in both directions, but I'm glad I didn't have to transit in ORD.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}