import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{3}( to |-)[A-Z]{3}";
final String string = "I recently traveled YWG-LHR and returned home from EDI to YWG with AC Rouge. I must say I was pleasantly surprised with how well the trip went in both directions, but I'm glad I didn't have to transit in ORD.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}