package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bhackerrank\b`)
var str = `I love #hackerrank
I just scored 27 points in the Picking Cards challenge on #HackerRank
I just signed up for summer cup @hackerrank
interesting talk by hari, co-founder of hackerrank`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}