import re
regex = re.compile(r"\bhackerrank\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("I love #hackerrank\n"
"I just scored 27 points in the Picking Cards challenge on #HackerRank\n"
"I just signed up for summer cup @hackerrank\n"
"interesting talk by hari, co-founder of hackerrank")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")