re = /\bhackerrank\b/mi
str = 'I love #hackerrank
I just scored 27 points in the Picking Cards challenge on #HackerRank
I just signed up for summer cup @hackerrank
interesting talk by hari, co-founder of hackerrank'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end