import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"javascript:void\\(0\\)\"[^>]*>(.*?)id=\"sw-slots-grid-line-break\"";
final String string = "<div id=\"tmm-grid-swatch-HARDCOVER\" class=\"a-column a-span6 a-text-left swatchElement selected celwidget\" role=\"listitem\" data-csa-c-id=\"rqzqyx-arj8qg-jifnrc-pelgtz\" data-cel-widget=\"tmm-grid-swatch-HARDCOVER\"> <span class=\"a-button a-button-selected a-spacing-none a-button-toggle format\" id=\"a-autoid-2\"><span class=\"a-button-inner\"><a href=\"javascript:void(0)\" role=\"radio\" aria-checked=\"true\" aria-current=\"page\" class=\"a-button-text a-text-left\" id=\"a-autoid-2-announce\"> <span class=\"slot-title\">\n"
+ " <span aria-label=\"Hardcover Format:\">Hardcover</span> <br> </span>\n"
+ " <span class=\"slot-price\">\n"
+ " <span aria-label=\"$16.94\" class=\"a-size-base a-color-price a-color-price\"> $16.94 </span> </span>\n"
+ " <br id=\"sw-slots-grid-line-break\">\n\n"
+ " </a></span></span> </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}