re = /<a href="javascript:void\(0\)"[^>]*>(.*?)id="sw-slots-grid-line-break"/i
str = '<div id="tmm-grid-swatch-HARDCOVER" class="a-column a-span6 a-text-left swatchElement selected celwidget" role="listitem" data-csa-c-id="rqzqyx-arj8qg-jifnrc-pelgtz" data-cel-widget="tmm-grid-swatch-HARDCOVER"> <span class="a-button a-button-selected a-spacing-none a-button-toggle format" id="a-autoid-2"><span class="a-button-inner"><a href="javascript:void(0)" role="radio" aria-checked="true" aria-current="page" class="a-button-text a-text-left" id="a-autoid-2-announce"> <span class="slot-title">
<span aria-label="Hardcover Format:">Hardcover</span> <br> </span>
<span class="slot-price">
<span aria-label="$16.94" class="a-size-base a-color-price a-color-price"> $16.94 </span> </span>
<br id="sw-slots-grid-line-break">
</a></span></span> </div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end