using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*-(\d+).(jpe?g|png|gif)$";
string input = @"http://localhost/images2/img-1.jpg
http://localhost/images2/img-23.jpg
http://localhost/images2/img-456.jpeg
http://localhost/images2/img-2134.gif";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}