const regex = /.*-(\d+).(jpe?g|png|gif)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*-(\\d+).(jpe?g|png|gif)$', 'gm')
const str = `http://localhost/images2/img-1.jpg
http://localhost/images2/img-23.jpg
http://localhost/images2/img-456.jpeg
http://localhost/images2/img-2134.gif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}