$re = '/.*-(\d+).(jpe?g|png|gif)$/m';
$str = 'http://localhost/images2/img-1.jpg
http://localhost/images2/img-23.jpg
http://localhost/images2/img-456.jpeg
http://localhost/images2/img-2134.gif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);