// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*-(\d+).(jpe?g|png|gif)$").unwrap();
let string = "http://localhost/images2/img-1.jpg
http://localhost/images2/img-23.jpg
http://localhost/images2/img-456.jpeg
http://localhost/images2/img-2134.gif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}