package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(/?\w+)]`)
var str = ` This is a [;;Text] and I want to match [center]everything without ;;[/center]`
var substitution = "<$1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}