$re = '`\[(/?\w+)]`m';
$str = ' This is a [;;Text] and I want to match [center]everything without ;;[/center]';
$subst = "<$1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;