# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:“[^“]*?”|"[^"]*?")\K(*SKIP)(?<=[?!.]["”])\s+|(?<=[?!.])\s+/\n/g;t' <<< "\"This is,\" she said, \"a bad idea.\"
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.
"