use strict;
my $str = '"This is," she said, "a bad idea."
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn\'t want that.
';
my $regex = qr/(?:“[^“]*?”|"[^"]*?")\K(*SKIP)(?<=[?!.]["”])\s+|(?<=[?!.])\s+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";