using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:“[^“]*?”|""[^""]*?"")\K(*SKIP)(?<=[?!.][""”])\s+|(?<=[?!.])\s+";
string substitution = @"\n";
string input = @"""This is,"" she said, ""a bad idea.""
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}