re = /(?:“[^“]*?”|"[^"]*?")\K(*SKIP)(?<=[?!.]["”])\s+|(?<=[?!.])\s+/
str = '"This is," she said, "a bad idea."
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn\'t want that.
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result