package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bsection\s*\d+(?:\.\d+)*:`)
var str = `section 1.1: Disability ........`
var substitution = "<hr/>$0"
fmt.Println(re.ReplaceAllString(str, substitution))
}