import Foundation
let pattern = #"\bsection\s*\d+(?:\.\d+)*:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"section 1.1: Disability ........"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<hr/>$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)