use strict;
my $str = 'section 1.1: Disability ........';
my $regex = qr/\bsection\s*\d+(?:\.\d+)*:/mp;
my $subst = '<hr/>$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";