#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Linus::[^\n:]*(?::(?::CASE|(?!:))[^\n:]*)*"
Local $sString = "Linus::AOPKNS::CASE::CASE" & @CRLF & _
"Linus::AOP::KNS::CASE" & @CRLF & _
"" & @CRLF & _
"Linus::AOPKNS::CASE" & @CRLF & _
"Linus::AOPKNS" & @CRLF & _
"Linus::AOPKNS::OK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")