$re = '/^Linus::[^\n:]*(?::(?::CASE|(?!:))[^\n:]*)*/m';
$str = 'Linus::AOPKNS::CASE::CASE
Linus::AOP::KNS::CASE
Linus::AOPKNS::CASE
Linus::AOPKNS
Linus::AOPKNS::OK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);