re = /^Linus::[^\n:]*(?::(?::CASE|(?!:))[^\n:]*)*/m
str = 'Linus::AOPKNS::CASE::CASE
Linus::AOP::KNS::CASE
Linus::AOPKNS::CASE
Linus::AOPKNS
Linus::AOPKNS::OK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end